PDA

View Full Version : Look what I fixed!



GameWatchGuy
08-30-2012, 12:32 AM
Hi.
Just fixed this one!
Used my new silver conductive glue and some resistor chips from another watch.

~John

764

slydc
08-30-2012, 02:19 AM
Hi John,

Cool to see that another Space Invaders is now working like a charm. What was the problem it had ?
This would be useful to know if this ever happens to any WWG's with the same type of problem and
to know how to fix it. :)

GameWatchGuy
08-30-2012, 12:44 PM
Hi.
I fixed all corrosion problems. It was near battery only. Fix cam out perfect and solid.
I couldn't understand why it wasn't working.
I finally noticed the screen was actually on and if I pushed I could barely see seconds changing.
I looked over chip again and noticed a piece broken off. It is like a square. The board had 2 other brown squares and 1 white. A resistor perhaps?
I dug through parts and found a similar sized brown square/resistor from a junked Timex. I glued using my silver glue and walla.
Watch works perfect. Sound is good, display is good.
It was missing a bottom band so I used a Pacman band I had which is almost identical to the original band. I had the top band.
I fixed a chipped corner of the case with a piece of plastic and super glue. Now solid!

All came out good and it's a wearable item. I played the game for a while and works nice.
~John

GameWatchGuy
08-30-2012, 12:51 PM
Oh.
I also fixed a Saturn 1 module I had. these have a tiny direct line from the negative to the chip. Often I have seen this line get corroded and interrupted.
I fixed with my silver glue.
It wouldn't turn on.
I disassembled several times trying to find anything wrong. I finally let it sit for a while with fresh battery in.

Often if a watch appears it should work I will let sit with a battery and sometimes they come back to life. Sometimes I let sit for weeks or months.
Sometimes I put inside a ziplock with silica packets if I suspect moisture. I fixed a Dukes watch this way once. I had let it sit for at least 2 weeks. One day walla, it's on!
Watches will really surprise you in this way.

Anyways I looked up at it and walla. All working except some parts of the screen. I pushed lightly on edges to make contact strip touch screen and crack. I broke a tiny chip off. The chip affects 2 digits on the seconds. It also made a small bleed appear.

It is running intermittently. I guess I can't win em all. Another lesson learned.

765766767
~John

slydc
08-31-2012, 11:21 PM
Hi John,

Thanks for all the details and infos, this will surely come handy in the future.
You also should add these infos in the section "fix, tips & tricks" for future reference.

And sorry to see that your Saturn 1 that it is not working properly anymore. I'll watch out
for the edges to clean it since i'm waiting an Armitron Saturn 1 to arrive.